
C-International Research Consultancy 

              Research Methodology Workshop 
                                  

                                              Module 2 
                

                          Basic Skills in MS Excel 
                                 https://doi.org/10.33515/cintarchrescon/rmw/m2 

 
 

 
 

1 

       
 
 

 
 To join our team of “Locum Research Consultancy Specialists and Workshop Facilitators”, please click 

on this link: http://www.cintarch.org/research-consultancy/ 
 
 To access our “Research Consultancy Services”, please click on this link: 

http://www.cintarch.org/research-consultancy-request/ 
 

 To submit your manuscript for publication in any of our journals, please click on this link: 
http://www.cintarch.org/submit-manuscripts/ 

 

  Contact details 

  Promoting integrity in research and mentoring researchers across the globe 

http://www.cintarch.org/research-consultancy/
http://www.cintarch.org/research-consultancy/
http://www.cintarch.org/research-consultancy/
http://www.cintarch.org/research-consultancy-request/
http://www.cintarch.org/research-consultancy-request/
http://www.cintarch.org/research-consultancy-request/
http://www.cintarch.org/research-consultancy-request/
http://www.cintarch.org/research-consultancy-request/
http://www.cintarch.org/research-consultancy-request/
http://www.cintarch.org/submit-manuscripts/
http://www.cintarch.org/submit-manuscripts/
http://www.cintarch.org/submit-manuscripts/
http://www.cintarch.org/submit-manuscripts/


                            Outline 

2 

• Features of MS Excel Workbook 

• Entering Data 

• Editing Data 

• Formatting Data 

• Formulas & Use of Functions 

• Creating Charts in MS Excel 

• Data Manipulation 

• Generating Random Numbers and Randomization into Groups 



 

 

         

 FEATURES OF MS EXCEL      

           WORKBOOK 
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Brief history 

• In 1978, Havard Business School’s student Dan Bricklin (the father of 
Modern Day Spreadsheets) had to do some analysis task for his case 
study. 

• He had only two options, either to do it manually or use a clumsy 
mainframe program, and so he thought there must be a better way. 

• He envisioned “an electronic blackboard and electric chalk in a 
classroom”. 

• By the fall of 1978, Dan Bricklin had programmed the first working 
prototype of his concept which he named VisiCalc (for visible 
calculator).  

• It was a relatively small program with few basic capabilities. It could 
only calculate data within a matrix of 5 columns and 20 rows. 

• He later hired Bob Frankston who made the program faster and with 
better arithmetic, and the program became an instant success. 
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Brief history contd. 

• In 1980, Sorcium developed a spreadsheet application called 
SuperCalc. 

• In 1982, Microsoft developed a spreadsheet  application called 
Muliplan. It differs from VisiCalc by using R1C1 addressing instead of 
A1 addressing used by VisiCalc. 

• In 1983, a team headed by Mitch Kapor bought VisiCalc and 
developed a more sophisticated spreadsheet called Lotus 1-2-3 (with 
charting, graphing and rudimentary database capabilities along with 
the basic arithmetic). 

• Lotus 1-2-3 became a new favorite in the industry, and outshined 
Microsoft’s Muliplan that was launched the previous year. 

• In 1985, in annoyance Microsoft developed another spreadsheet 
program called Microsoft Excel (Excel 1.0), and periodically released 
newer versions(1987, Excel 2.0; 1990, Excel 3.0; 1992. Excel 
4.0;…….Ms Office 2007, 2010, 2013, 2016) to maintain their lead in 
the industry. 5 



Starting MS Excel 
• Double click on the MS Excel icon (if you have it on your desktop). 

• Alternatively, click the start button and then select: 

     All programs > Microsoft Office > Microsoft Excel 

• A new empty workbook (consisting of three worksheets) will be 
displayed on your screen (as shown in the next slide). 
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Features of MS Excel Workbook 
• Title bar: Appears at the top of the program window and displays the name of the 

workbook and program. The buttons on the right side of the Title bar are used to 
minimize, restore and close the program window. 

• Quick Access toolbar: Appears on the left side of the Title bar and contains 
frequently used commands that are independent of the tab displayed on the 
Ribbon. 

• Ribbon: Extends across the top of the program window, directly below the Title bar, 
and consists of a set of tabs, each of which contains groups of related commands. 
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Features of MS Excel Workbook contd. 
• Formula bar: Appears below the Ribbon and displays the data or formula stored in 

the active cell. It can also be used to enter or edit a formula, a function, or data in a 
cell. 

• Name box: Appears on the left side of the Formula bar and displays the active cell 
address or the name of the selected cell, range , or object. 

• Workbook window: Appears below the Formula bar and displays a portion of the 
active worksheet. 
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Features of MS Excel Workbook contd. 
• Sheet tab: Each tab represents a different worksheet in the workbook. A workbook 

can have any number of worksheets, and each worksheet has its name displayed 
on its tab. 

• Scroll bars: Appear along the right side and bottom of the workbook window  and 
enable you to scroll through the workbook. 

• Status bar: Appears at the bottom of the program window and displays various 
messages. The tools on the right side of the Status bar can be used to display the 
worksheet in a variety of views and to change the magnification of the worksheet. 9 



Quick Access toolbar 

 
• The Quick Access toolbar provides one-click access to commonly 

       used command and options. 

• By default, it is located on the left side of the Title bar and displays 

       the Save, Undo, and Redo buttons. 

• To add a command to the Quick Access toolbar: 

      On the Ribbon, right-click the command that you want to add,  

      and then click Add to Quick Access toolbar on the shortcut menu. 

• To remove a command from the Quick Access toolbar: 

      On the Quick Access toolbar, right-click the command that you want to remove,  

      and then click Remove from Quick Access toolbar on the shortcut menu. 

• To customize the Quick Access toolbar: 

      On the arrow on the right side of the Quick Access toolbar, a menu which  

      Includes additional commands and options that can be used to customize the  

      toolbar is displayed. Select the item(s) of your choice. 
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Ribbon 

 
• The  Ribbon is designed to help you quickly find the commands that you need to 

complete a task. 

• It consists of a set of task-specific tabs. The main tabs are visible at all times; other 
tabs, known as contextual tabs, appear only when you create  or select certain 
types of objects (e.g., images, tables, charts). These tabs are indicated by colored 
headers and contain commands that are specific to working the selected object. 

• Clicking a tab displays a set of related commands that are organized into logical 
groups. 

• A dialog box launcher appears in the lower-right corner of most groups on the 
Ribbon. Clicking it opens a related dialog box or task pane which offers additional 
options or more precise control than the commands available on the Ribbon. 

• If a command on the Ribbon appears dimmed, it is unavailable. 
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Ribbon tabs 
• File tab: This tab displays the backstage view which contains commands 

      related to managing files and customizing the program. The File tab 

      replaces the Microsoft Office button and File menu used in earlier  

      releases of Microsoft office. 

      Clicking on the File tab displays a dialog box which contains options such  

      as Save, Save As, Open, Close, Info, Recent, New, Print, Save & Send etc. 

 

• Home tab: This is the most used tab;   it incorporates all text and cell formatting 
features such as font and paragraph changes. It also includes basic spreadsheet 
formatting elements such as text wrap, merging cells and cell style. 

 

 

 

• Insert tab: This tab allows you to insert a variety of items into a document from 
pictures, clip art, and headers and footers. 
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Ribbon tabs contd. 
• Page Layout tab: This tab has commands to adjust page such as margins, orientation 

and themes. The commands affect the overall appearance of a worksheet. 

 

 

 

 

• Formulas tab: This tab has commands to use when creating formulas. The tab has an 
immense function library which can assist when creating any formula or function in 
your spreadsheet. 

 

 

 

• Data tab: This tab allows you to modify worksheets with large amounts of data by 
sorting and filtering as well as analyzing and grouping data. 
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Ribbon tabs contd. 
• Review tab: This tab allows you to correct spelling and grammar 

issues as well as set up security protections. It also provides the track 
changes and notes feature providing the ability to make notes and 
changes to someone’s documents. 

 

 

 

 

 

• View tab: This tab allows you to change the view of your document 
including freezing or splitting panes, viewing gridlines and hide cells. 
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Workbooks / Worksheets 
• An Excel file is called a workbook. Each new workbook contains three 

blank worksheets (named Sheet 1, Sheet 2, and Sheet 3); you can 
insert additional worksheets or delete existing worksheets as needed.  

• Each worksheet consists of 1,048,576 rows (numbered 1 through 
1,048,576) and 16,284 columns (labelled A through XFD). 

• The box formed by the intersection of a row and a column is called a 
cell. 
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Workbooks / Worksheets contd. 
• Cells are used to store data, and each 

    cell is identified by its address which consists of 

     its column letter and row number (e.g., cell A1 

     is the cell in the first column and first row). 

• Only one cell can be active at a time. The active 

      cell has a thick black border around it and its 

      address appears in the Name box on the left 

      side of the Formula bar. 

 

• A group of cells is called a range.  

• A range is identified by the addresses of the 

      cells in the upper-left and lower-right  

      corners of the selected block of cells,  

       separated by a colon (e.g., A1:C10). 
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Navigating within a worksheet 
• Use the arrow keys, or [PAGE UP] and [PAGE DOWN], to move to a 

different area of the screen. 

• [CTRL] + [HOME] will take you to cell A1.     

• [CTRL] + [PAGE DOWN] will take you to the last row (i.e., 1048576) on 
the worksheet, and [CTRL] + [PAGE UP] will bring you back to the first 
row. 

• To go to a specific cell: 

     Press *F5+, the ‘go to dialog box’ will appear, type in the address of  

     the desired cell, and click OK. 

     Alternatively, type the cell address in the name box above column A  

     and press [ENTER]. 

 

To select cells 

• Use the arrow keys to move to the desired cell. 

• To select multiple cells, hold down the [SHIFT] key while the first cell 
is active, and then use the arrow keys to select the rest of the range. 
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Selecting rows 
• To select all the cells in a particular row, just click on the row number (1,2,3, etc.) at the 

left edge of the worksheet. 
• Hold down the [SHIFT] key and then use the arrow keys to select multiple adjacent 

rows. 
• Hold down [CTRL] key if you want to select a set of non-adjacent rows. 

 
Selecting columns 
• To select all cells in a particular column, click on the column heading (A,B,C, etc.) at the 

top edge of the worksheet. 
• Hold down the [SHIFT] key and then use the arrow keys to select multiple adjacent 

columns. 
• Hold down [CTRL] if you want to select a set of non-adjacent columns. 

 
To select all the cells  in a worksheet 
• Click on  the square to the immediate left of Column A heading  
      (just above the label for Row 1). 
• Alternatively, you can also press [CTRL] + [A] 
 
Closing MS Excel 
• Click the File tab, and then click exit, or click on the Close Window 
      button in the upper right corner of the program window. If you have 
      unsaved data you will be prompted to save the changes before exiting. 
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Get a workbook 

• Before you start entering data, you need to decide whether this is a completely 
new project deserving a workbook of its own, or whether the data to be entered 
relates to an existing workbook. 

To create a new workbook from inside Excel: 
• Click on the File tab, select New and then double click Blank workbook. 

• Sheet 1 of a new workbook will be displayed on your screen, with cell A1 active 

 

 

 

 

 

To open an existing workbook from inside Excel: 
• Click on the File tab, click Open, and then  

      navigate to the drive and folder containing 

      the file you want to open. 

• Double-click on the required file name  

      (or click Open). 
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Types of data /Entering text 

• Different types of data can be entered into the cells on a worksheet. 
these include text, numbers and dates. 

Entering text: 
• You can enter text in a worksheet to serve as label for values, headings for columns, 

or instructions about the worksheet. 

• Text is defined as any combination of letters (i.e, alphabets) and numbers. 

• Text automatically aligns to the left in a cell. 

• If you enter text that is longer than its column’s current 

     width, the excess characters appear in the cell to the right, as  

     long as the cell is empty.   

 

• If the adjacent cell is not empty, the long text entry  

     appears truncated at the cell border. 

 

• The characters are not actually deleted and will appear if the width of the column 
is adjusted to accommodate the long text entry. 
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Entering text contd. 

To enter text: 

• Select the cell in which you want to enter text. 

• Type the desired text. 

• Press [ENTER] to move to the next row, or [TAB] to move to the next 
column. 

      Until you’ve pressed *ENTER+ or *TAB+, you can cancel the entire data  

      entered into the cell by pressing [ESC], or cancel the data one by one  

       by pressing [BACKSPACE]. 

To enter a line break in a cell: 

• Select the cell and type the desired text in the first line 

• Press [ALT] + [ENTER] and type the desired text 

     in the next line, and then continue like that for the subsequent lines. 
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Entering text contd. 

• In addition to alphabetic characters and numbers, text can also 
include punctuation marks and special characters (like check marks). 
 

 

 

 

• Text fields are not included in numeric calculations. 

• If you want Excel to treat a number as text, then you should precede 
the number with a single quotation mark (‘). This can be useful when 
entering for example a phone number that starts with 0, since 
leading zeros are not displayed for Excel numbers. 
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Entering numbers 

• Numeric entries contain only numbers and are automatically aligned to the 
right in a cell. 

• Numbers can exist as independent values, or they can be used in formulas 
to calculate other values. 

• You can enter whole numbers (such as 1, 10, or 100),decimals (such as 0.1, 
0.5, or 0.9), negative values (such as -1, -10, or -100), percentages (such as 
10% or 50%), and currency values (such as N500, or N1000). 

• Numbers automatically aligns to the right in a cell. 
• A number that does not fit within a column is displayed as “#######” 
     or displays the first few digits and indicate that there are still other digits     
     not displayed e.g.,  “9.91E+10”  
     
 
 
To accommodate the number, increase the column width. 
       
 
 
• . 
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Entering numbers contd. 

To enter a number: 
• Select the cell in which you want to enter the number. 

• Type the desired number. 

• Press [ENTER] to move to the next row, or [TAB] to move to the next column. 

      Until you’ve pressed *ENTER+ or *TAB+, you can cancel the entire data  

      entered into the cell by pressing [ESC], or cancel the data one by one  

       by pressing [BACKSPACE]. 

 

To enter a line break in a cell: 

• Select the cell and type the desired number in the first line 

• Press [ALT] + [ENTER] and type the desired number 

     in the next line, and then continue like that for the subsequent lines. 
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Entering Dates and Time 

• Excel treats dates and time as special type of numeric values. 

To enter a date: 
• Select the cell in which you want to enter the date. 

• Type the day, month,  and year, with each number separated by a forward slash (/) 
or a hyphen (-), and then press the Enter key. 

 

To enter a time: 
• Select the cell in which you want to enter the time. 

• Type the hour, a colon (:), and the minutes, press the Spacebar, type a for A.M.  

      or p for P.M., and then press the Enter key. 
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Deleting data 

To delete data that’s already entered into a worksheet: 

• Select the cell or cells containing the data to be deleted. 

• Press the [DELETE] key on the keyboard. 

• The cells remain in the same position as before but their contents are 
deleted 

 

Moving data: 

• To move an already entered data to a different area of the worksheet. 

• Select the cells to be moved (they will become highlighted). 

• Move the cursor to the border of the highlighted cells. When 

      the cursor changes from a white cross to a four-headed arrow  

     (the move pointer), hold down the left mouse button. 

• Drag the selected cells to a new area of the worksheet,  

      then release the mouse button. 
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Copying data 

To copy existing cell content to another area of the worksheet: 

• Select the cells you want to copy (they will become highlighted).. 

• Move the cursor to the border of the highlighted cells while holding 
down the [CTRL] key. When the cursor changes from a  

     white cross to a hollow left-pointing arrow (the copy  

      pointer), hold down the left mouse button. 

• Drag the selected cells to a second area of the worksheet (where you 
want to  paste the cells), then release the mouse button. 

 

     You can also copy the selected data using the copy option on the    

     Home tab or [CTRL] + [C]. Then click in the top left cell of the  

     destination area and paste the data with the paste option  

     or [CTRL] + [V]. 
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Copying data contd. 

To copy the contents of one cell to a set of adjacent cells: 

• Select the initial cell and then move the cursor over the small square 
in the bottom right-hand corner (the fill handle). 

  

•  The cursor will change from a white cross       to a black cross     . 

• Hold down the left mouse button and drag to a range of adjacent 
cells. The initial cell contents will be copied to the other cells. 

• If the original cell contents end with a number, the number will be 
incremental in the copied cells. 
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Copying data contd. 

Using AutoFill: 

• This makes it easy to repeat a data series (such as the days of the week, months of 
the year, or a numbers series such as odd numbers) over a range of cells. 

• Enter the start of the series into a few adjacent cells (enough to show the 
underlying pattern). 

• Select the cells that contain series data. 
• Move the cursor over the small square in the bottom right-hand corner of the 

selection (the fill handle). Hold down the left mouse button and drag to a range of 
adjacent cells. 

• The target cells will be filled based on the pattern of the original series cells. 
 

Saving the workbook: 
• Click the File tab and select Save, or click the Save icon on the Quick access toolbar. 
      If the workbook has been saved before, the workbook will be saved again with the  
      same name and location.  
•  If it’s the first time of saving the workbook, then the Save As dialogue box will 

open. 
• Click the drop-down arrow next to Save In to select the desired drive and folder. 
• Type the new file name in the File name field. 
• Click the Save button. 
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          EDITING DATA 
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Editing cell contents 

• In data entry mode, when you move the cursor to a new cell, 
anything you type replaces the previous cell contents. 

• Edit mode allows you to amend existing cell contents without having 
to retype the entire entry. 

• While in the edit mode, many of the Ribbon commands are disabled. 

 

To enter edit mode: 
The ways to enter edit mode include: 

• Double-click (with the left mouse button) on the cell whose contents you want to 
edit. 

• Click to select the cell you want to edit and press  [F2] key. 

• Click to select the cell you want to edit, and then click anywhere in the  formula 
bar.  Edit the cell contents as displayed in the formula bar. 
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Editing cell contents contd. 

To edit cell contents: 

• To delete characters, use the [BACKSPACE] key to delete the 
cell contents to the left of the cursor; or [DELETE] key to 
delete the cell contents to the right of the cursor. 

• To insert characters, click where you want to insert them 
and type. 

• To force a line break within the current cell contents, press 
[ALT] + [ENTER]. 

 

To exit  edit mode: 

• Exit edit mode by pressing [ENTER]. 
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Inserting or deleting cells 
• A new cell can be inserted above the current active cell, in which case the active cell and those 

below it will each move down one row. 
• A new cell can also be inserted to the left of the current active cell, in which case the active cell 

and those on its right will each move one column to the right. 
 

To insert a cell: 
• Select the cell next to which you want to insert a new cell 

• On the Home tab, find the cells group. 
 
 
 
 
 
 
 
 
 

• Click insert followed by insert cells. 
 
 
 
 

• A dialog box will open. Click the direction in which 
         you want the surrounding cells to shift, and click OK. 
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Alternatively: You can right-click on the active cell and  
select Insert on the pop-up menu. 



Inserting or deleting cells contd. 

 

To delete a cell: 
• Select the cell that you want to delete. 
• On the Home tab, find the cells group. 

 
 
 
 
 
 
 
 

• Click delete followed by delete cells. 
 
 
 
 

• A dialog box will open. Click the direction in which 
         you want the surrounding cells to shift, and click OK. 
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Alternatively: You can right-click on the active cell and  
select Delete on the pop-up menu 



Inserting  or deleting rows 

• When you insert a row, the new row will be positioned above the row containing the 
active cell. 

To insert a row: 

• Select a cell in the row above which you want to insert a new row 

 

 

 

 

 

• On the Home tab, find the Cells group and click Insert  

       followed by Insert Sheet Rows. 

 

• A new row will be inserted above the current row. 
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Inserting  or deleting rows contd. 

• When you delete a row, all the rows below it will move up by one. 

 

To delete a row: 

• Select a cell in the row that you want to delete. 

 

 

 

 

 

• On the Home tab, find the Cells group and click Delete  

       followed by Delete Sheet Rows. 

 

• The row containing the active cell will be deleted. 
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Inserting  or deleting columns 

• When you insert a column, the new column will be positioned on the left of the column 
containing the active cell. 

To insert a column: 

• Select a cell in the column to the left of which you want to insert a new column. 

 

 

 

 

 

• On the Home tab, find the Cells group and click Insert  

       followed by Insert Sheet Columns. 

 

• A new column will be inserted to the left of the current column. 
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Inserting  or deleting columns contd. 

• When you delete a column, all the all the columns on its right will move left by one. 

 

To delete a column: 

• Select a cell in the column that you want to delete. 

 

 

 

 

 

• On the Home tab, find the Cells group and click Delete  

       followed by Delete Sheet Columns. 

 

• The column containing the active cell will be deleted. 
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Alternative way of Inserting  or deleting rows and columns  

• An alternative way of inserting or  

    deleting rows and columns is to  

     right-click on the relevant cell. 

 

• Then use the pop-up menu to insert or  

    delete the row or column of choice. 

 

• The menu can also be used to 

     format the data contained in the  

    worksheet (this shall be covered in  

     Module 4). 
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Inserting or deleting a worksheet  

To insert a worksheet at the end of the existing worksheets: 

• Click the Insert Worksheet tab at the bottom of the screen. 

• The shortcut key for this is [SHIFT] + [F11]. 

 

 

To insert a new worksheet  before an existing worksheet: 

• Select the worksheet before which you want to insert a new worksheet. 

• On the Home tab, find the Cells group and click Insert followed by Insert 
Sheet. 

• A new worksheet will be inserted before the current worksheet. 

 

To delete a worksheet:  

• Select the worksheet that you want to delete. 

• On the Home tab, find the Cells group and click Delete followed by Delete 
Sheet. 

• The current worksheet will be deleted. 
41 



Moving /copying or renaming a worksheet 

To move or copy a worksheet: 

• Right-click on the worksheet tab and select Move or Copy from the pop-up 
menu. A dialog box will open:  

 

• The To book field allows you to move or copy 

      the current worksheet to another workbook. 

• The Before sheet field allows you to specify 

      the new position of the worksheet. 

• The Create a copy checkbox lets you specify  

      whether the worksheet should be moved or  

     copied. 

 

Renaming a worksheet: 

• Right-click on the worksheet tab, and select Rename from the pop-up 
menu. Type the new worksheet name and press [ENTER]. 
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Formatting cell and cell contents 

• You can make a worksheet easier to read and understand by 
applying different types of formatting to cells and cells contents. 

• This includes changing the font, font size, font style, font color, 
adding cell borders and changing the background of cells. 

• Since formatting is attached to the cell and not the entry, you 
can format a cell before or after you enter the data. 

• The Font group on the Home tab of the Ribbon provides quick 
access to the most commonly used formatting commands. To 
apply any of these, just select the cell or cells that you want to 
format, and then click on the desired icon. 
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Formatting cell and cell contents contd. 

• The commonly used formatting attributes include: 
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Changing the Font and Font size 

• A font is defined as a group of characters sharing similar type attributes. The default 
font in new Excel 2010 workbooks is Calibri. 

• Font size is measured in points. The larger the font size, the larger the data. The default 
font size in new Excel 2010 workbooks is 11 points. 

 

To change the Font: 

• Select the cell that you want to format. 

• On the Home tab, in the Font group, click the Font arrow                         and select the 
desired font from the list. 

 

To change the Font Size: 

• Select the cell that you want to format. 

• On the Home tab, in the Font group, click the Font Size arrow                   and select the 
desired font size from the list. 

• If a font size you want is not listed in the Font Size list, click in the Font Size box, type 
the desired number, and then press the Enter key. 

• You can also change the font size by clicking the Increase Font Size button            or 
Decrease Font Size button              in the Font group on the Home tab of the Ribbon. 
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Applying Font Styles 

• Font styles are attributes such as bold, italic and underline. They are used to emphasize 
important data in a worksheet. 

• Bolding makes the character darker, Italicizing slants the characters to the right, while 
underlining adds a line below the character in a cell, not the cell itself. 

 

To bold or italicize data: 

• Select the cell that you want to format. 

• On the Home tab, in the Font group, click the Bold button          or the Italic button         . 

 

To underline data: 

• Select the cell that you want to format. 

• On the Home tab, in the Font group, do one of the following as applicable. 

       - To apply a single underline, click the Underline button. 

       - To apply a double underline, click the Underline arrow, and then click Double   

          Underline. 
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Adding Cell Borders 

• You can add borders to any or all sides of a single cell or range. Excel 
includes several predefined border styles that you can use. 

 

To add a cell border: 

• Select the cell or cells to which you want 

     to add a border. On the Home tab, in the  

     Font group, click the Borders button to apply 

     the most recently used border style, or click  

     the Borders arrow and select a different border 

     style from the menu. 

• You can remove a cell border by clicking the  

     Borders arrow, and then clicking No Border. 
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Changing the Font Color and Fill Color 

• You can change the font color or fill color of cells to emphasize important data or add 
visual impact to a worksheet. 

• Fill color refers to the background color of a cell. 

 

To change the Font Color: 

• Select the cell that you want to format. 

• On the Home tab, in the Font group, click the Font Color  

      button to apply the most recently used color, or click the  

     Font Color arrow and select a different color from the  

     color palette. 

 

To change the Fill Color: 

• Select the cell that you want to format. 

• On the Home tab, in the Font group, click the Fill Color  

       button to apply the most recently used color, or click the 

      Fill Color arrow and select a different color from the color  

      palette. 

• You can remove a fill color by clicking the Fill Color arrow, and then clicking No Fill. 
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Formatting Numbers 

• You can apply number formats to cells containing numbers to better 
reflect the type of data they represent. 

• You can display a numeric value as a percentage, as currency, as a 
date or time, etc. 

• The Number group on the Home tab of the Ribbon provides quick 
access to the most commonly used number formats. 

 

 

 

 

 

• Formatting does not change the actual value stored in a cell. The 
actual value is used in calculations and is displayed in the Formula 
bar when the cell is selected. 
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Formatting Numbers contd. 

To format Numbers: 

• Select the cell that you want to format. 

• On the Home tab, in the Number group, do one of the 

       following as applicable: 

      - Click the Accounting Number Format button             to display the number with a  

         dollar sign, comma separators, and two decimal places. You can select a different  

         symbol by clicking the Accounting Number Format and selecting the desired symbol  

         from the menu. 

     - Click the Percent Style button              to convert the number to a percentage and  

        display it with a percent sign. 

    -  Click the Comma Style button            to display the number with comma separators and  

        two decimal places.  

 

To change the number of decimal places: 

• Select the cell that you want to format. 

• On the Home tab, in the Number group, do one of the following as applicable: 

      - Click the Increase Decimal button         to increase the number of decimal places. 

      - Click the Decrease Decimal button        to decrease the number of decimal places. 
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Formatting Numbers contd. 

• Alternatively numbers can be formatted using the General  menu 

 

To format numbers using the General menu: 

• Select the cell that you want to format. 

• On the Home tab, find the Number group,  

     click the General arrow and select the 

     type of formatting you which to do from  

     the options in the Number Format menu. 
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Positioning Cell Contents 

• The Alignment group on the Home tab on the Ribbon contains the most 
useful commands for positioning data within cells. They can be used to 
change the alignment, indentation, and orientation of cell data; wrap data 
within cells, as well as merge cells. 

 

 

• Click the dialog box  

      launcher         in the 

     Alignment group to open 

     the Alignment tab of the 

     Format Cells dialog box. 
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Aligning Data 

• The horizontal and vertical alignment of cell data can be changed.  

• By default, text is aligned to the left edge of a cell and numbers are aligned 
to the right. 

 

To align data: 

• Select the cell that contains the data you want to align. 

• On the Home tab, in the Alignment group,  

     click the desired alignment button. 

 

• The Alignment buttons and their functions are as indicated in the Table  
below: 
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Indenting Data 
• Indenting moves data away from the edge of the cell. This is often used to 

indicate a level of less importance (such as a subtopic). 

• Each click increments the amount of indentation by one character. 

 

To indent data: 

• Select the cell that contains the data you want to indent. 

• On the Home tab, in the Alignment group,  

     click the Increase Indent button         the number of times that you want the  

     data indented. 

 

 

 

 

 

 

• You can decrease or remove the indentation applied to cell data by clicking 
the Decrease Indent button         in the Alignment group. 55 



Rotating Data 
• Data can be rotated clockwise, counterclockwise, or vertically within a cell. 

• This is often used to label narrow columns or to add visual impact to a 
worksheet. 

 

To rotate data: 
• Select the cell that contains the data you want to rotate. 

• On the Home tab, in the Alignment group,  

     click the Orientation  button and select the desired option 

     from the menu. The row height automatically adjusts to fit 

     the rotated data. 

 

 

 

 

 

 

• You can restore the data to its default orientation by clicking the 
Orientation button and selecting the currently selected orientation. 56 



Wrapping Data 
• Wrapping displays data on multiple lines within a cell. 

• The number of wrapped lines depends on the width of the column and the 
length of the data. 

 

To wrap data: 
• Select the cell that contains the data you want to wrap. 

• On the Home tab, in the Alignment group,  

     click the Wrap Text  button       . The row height automatically adjusts to fit 

     the rotated data. 

 

 

 

 

 

 

• You can restore the data to its original format by clicking the Wrap Text 
button again. 
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Merging Cells 
• Merging combines two or more adjacent cells into one larger cell. It is a way of creating 

labels that span several columns. 

• If the cells you intend to merge have data in more than one cell, only the data in the 
upper-left cell remains after you merge the cells. 

To merge cells: 

• Select the cells that you want to merge. 

• On the Home tab, in the Alignment group, click the Merge & Center arrow and select 
one of the following options as applicable. 

      - Merge & Center: merges the selected cells into one cell and centers the data. This is  

         the default action of the button. 

     -  Merge Across: Merges each row of the selected cells into a larger cell. 

     -  Merge Cells: Merges the selected cells into one cell. 

        

      

 

 

 

• You can split a merged cell by selecting it, clicking the Merge & Center arrow, and then 
clicking Unmerge Cells. 
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Copying Cell Formats 
• After formatting a cell, you might want to apply the same formats to other cells in the 

worksheet.  

• Rather than selecting each cell and applying the individual formats, you can use the 
Format Painter command to quickly copy the formatting of one cell and apply it to 
other cells. 

 

To copy cell formats: 

• Select the cells that has the formatting you want to copy. 

• On the Home tab, in the Clipboard group, click the Format Painter button          . The 
mouse pointer changes to a plus sign with a paintbrush           . 

• Select the cell to which you want to apply the copied formatting. 

 

 

 

 

 

• If you want to apply the copied formatting to all 

      the cells in the worksheet click on the square to the 

     immediate left of Column A heading (just above the label for Row 1). 
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If you want to apply the copied formatting to more 
than one cell, double-click the Format Painter button 
instead of single-clicking it. This keeps the Format 
Painter active until you press the Esc key. 

 



Applying Cell Styles 
• A cell style is a defined collection of formats (font, font size, font color, cell border, fill 

color, etc) that you can use to quickly format the cells in a worksheet.  

• In addition to saving time, it can help you keep formatting consistently throughout the 
worksheet.  

• Excel includes several predefined styles for different worksheet elements such as 
headings, numbers, calculations, notes, etc. 

To apply a style: 

• Select the cell that you want to format. 

• On the Home tab, in the Styles group, click the Cell Styles  

      button and select the desired style from the gallery. 

 

 

 

 

 

 

60 



Formatting rows and columns 

• Any of the cell formatting options 
shown on the left can easily be 
applied to all the cells contained in 
one or more rows or columns. 

• Simply select the rows or columns by 
clicking on the row or column labels, 
and then click on the formatting 
icons that you want to apply. 

 

To manually adjust row height and 
column width: 

• To manually adjust the height of a 
row, click and drag the boundary 
between two row labels. 

• To manually adjust the width of a 
column, click and drag the boundary 
between two column headings. 
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Formatting rows and columns contd. 

To automatically adjust row height and column width: 

• Select the rows or columns that you want to format. 

• On the Home tab, in the Cells group, click the Format  

      button and select either of Autofit Row Height or  

      Autofit Column Width in the Cell Size menu as applicable. 

 

 

 

 

 

To set a row height or column width: 

• Select the rows or columns that you want to format. 

• On the Home tab, in the Cells group, click the Format  

      button, select either of Row Height or Column Width 

      in the Cell size menu as applicable, type 

      the value that you want in the box that appears 

      and click OK. 

       

 

 

 

 

 

• If you want to apply the copied formatting to more than one cell, double-click the 
Format Painter button instead of single-clicking it. This keeps the Format Painter active 
until you press the Esc key. 
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Adding a Comment to a Cell. 
• A comment can be added to any cell on your spreadsheet. 

• When you hover your mouse pointer over a cell that contains a comment, you will see 
the comment appear in a sort of sticky - note. 

 

To add a comment to a cell: 

• Select the cell that you want to add a comment. 

• On the Review tab, in the Comments group, click the New Comment  

      button, press the backspace key to delete the word “Test” in the textbox that appears to  

      the right of the selected cell and type in your comment. Then click on any other cell.      

      selected cell. 
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Adding a Comment to a Cell contd. 

• To increase or decrease the size of the comment area, hold down the 
left mouse button over the white circles in the border of the textbox 
and drag. 

• When you have finished typing your comment, click on any other cell. 
The comment will disappear. 

• The cell in which the comment has been entered now has a red 
triangle in the top right corner. This indicates that it contains a 
comment. 

• If you move your mouse pointer over the cell, the comment will 
appear. 

• To edit the comment, right click the cell that contains the comment, 
then from the menu that appears, select Edit Comment. 

• To delete the comment, right click the cell that contains the 
comment. Then from the menu that appears, select Delete 
Comment. 
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Hiding rows and columns 
 

To hide or unhide rows and columns 

• Select the rows or columns that you want to hide. 

• On the Home tab, in the Cells group, click the 
Format button and select Hide & Unhide (below 
Visibility), and then select the appropriate option 
in pop-up menu that comes up. 

 

 

 

 

 

 

Easiest way to hide or unhide a row or column: 

• Select the row or column heading. 

• Right-click to view the pop-up menu. 

• Then select Hide or Unhide. 
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Keeping row and column headings in view 

• It is often necessary to keep particular rows and columns visible as you scroll through 
the worksheet.  

 

To keep particular rows and columns visible: 

• Select a cell immediately below the rows that you want to remain visible, and 
immediately to the right of the column that you want to remain visible. 

• On the View tab, click  Freeze Panes, and select the first option.  
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If Freeze Panes has already  
been applied, then the option 
automatically changes to 
 Unfreeze Panes. 
 



 

 

      

           FORMULAS  

                      & 

    USE OF FUNCTIONS 
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Formulas in Excel 
• Formulas are equations that perform calculations on values in the worksheet. 

• A formula always starts with an equal sign (=). This lets Excel know that it’s going to 
have to work something out. 

• In the body of the formula, you’re going to tell Excel what you want it to calculate. 

• A formula can contain any or all of the following parts. 

      1. Functions: A function, such as PI() or SUM(), starts with an equal sign (=). 

       2. Cell reference: You can refer to data in worksheet cells by including cell reference  

            (e.g., A1, B1, C1, etc.) in the formula. 

       3. Constants: You can also enter constants  such as numbers or text values (e.g., 2, 3, 4,  

          20%, 25%, etc.) directly into the formula. 

        4. Operators: These are the symbols that are used to specify the type of calculation  

            that you want the formula to perform. 

            The operators that are used include: 

             +  addition 

             -  subtraction 

             *  multiplication 

              /  division 

                exponentiation (‘to the power of’) 
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Formulas in Excel contd. 

Order of operations in Excel 

The operations in Excel are evaluated in particular order of precedence. 

• Operations inside brackets are calculated first 

• Exponentiation is calculated second. 

• Multiplication and division are calculated third. 

• Addition and subtractions are calculated forth. 

• When you have several items at the same level of precedence, they 
are calculated from left to right. 

      Examples: 

       = 10+ 5*3-7           (result: 10+15-7 = 18) 

       = (10+5)*3-7         (result: 15*3-7 =38) 

       = (10+5) * (3-7)    (result: 15 * -4  = -60) 

 

• If you are not sure how a formula will be evaluated, use brackets. 69 



Formulas in Excel contd. 

To create a simple formula: 

• Click the cell in which you want to enter the formula. 

• Type = (equal sign) 

• Enter the formula by typing the constants and operators that you 
want to use in the calculation. 

• Press ENTER. 

• The constants and operators entered into the cell become replaced 
by the result (i.e., 18). 
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Formulas in Excel contd. 

To create a formula with cell reference: 
• Click the cell in which you want to enter the formula (G2). 

• In the Formula bar at the top of the Excel window that you use 

     type = (equal sign).  

• Click on the 1st cell you want in the formula (B2). 

• Enter the desired operator (*). 

• Click on the next cell you want in the formula (C2), and enter the desired operator 
again. Continue until the formula is complete. The formula entered in the Formula bar 
also shows in the cell selected for the result.  

 

 

 

 

 

 

 

 

• Press ENTER key. The result appears in cell G2, use the fill handle to fill in the results 

      for cells  G3 and G4. 
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Formulas in Excel contd. 
To create a formula with Function: 

• Click the cell in which you want to enter the formula (F2). 

• Click Insert Function             on the formula bar                                 .  

      Excel inserts the equal sign (=) for you.  

• Select the function that you want to use.  

      If you’re not sure which function to use, type 

      a question that describes what you want to 

      do in the Search for a function  box  

      (e.g., “add numbers” returns the SUM 

      function) or browse from the categories in 

      the Or select a category box. 

• Select the desired function in the  

      Select a function menu and click OK. 

• Enter or modify the arguments in the Function Arguments box that comes 

up, and click OK. The result appears in cell G2, use the fill handle to fill 
in the results for cells  G3 and G4 . 
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Formulas in Excel contd. 
Use of Auto Sum 
• Auto Sum is used to summarize values quickly. 

To use Auto Sum: 

• Select the cell where you would like your formula’s solution to appear. 

• On the Home tab, find the Editing group and click Auto Sum to  sum your 
numbers (if S/N and Adm. No. were entered as text). 

• If S/N and Adm. No. were entered as numbers, click the arrow next to Auto 
Sum and click  More Functions, then enter C4:G4 in the Function 
Arguments box and click OK.  

        

 

 

 

 

 

73 

 The Function Arguments are used to specify the scope and  
     direction of summation (i.e., cells across row s or  in a column)  
 Alternatively, select/highlight the cells to be summed up, and 
    the cell where you want your formula’s solution to appear  
    and click Auto Sum. 



Formulas in Excel contd. 
Example 1_Multistage computation of CATs result  

• You are coordinating a course, the results of the students 
performance in the two continuous assessment tests conducted 
have been entered as shown in columns B to K. 

• You are to compute the sum of the scores for CATs 1 and 2 in 
column L and convert it to a maximum of 30% in column M. 
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Formulas in Excel contd. 
Example 1_Multistage computation of CATs result contd. 
 

 

 

 
Stage 1_Computation of Total for CATs 1 and 2 (in Column L): 

• Click on cell L4. 

• Click on the Formula bar, type in = SUM(B4:K4), and click [ENTER]. This adds the 
values in cells B4 to K4, and displays the result in cell L4.  

• Press [ENTER] to display the result (i.e 87.5). 
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Formulas in Excel contd. 
Example 1_Multistage computation of CATs result contd. 
 

 

 

 
Stage 2_Computation of Final CATs score to a maximum of  30marks (in Column M): 

• Click on cell M4. 

• Click on the Formula bar, type in =(L4/180)*30, and click [ENTER]. This works out  
the value in cell L4 adjusted to a maximum of 30 marks instead of 180 marks, and 
displays the result in cell M4.  

• Press [ENTER] to display the result (i.e 14.58). 
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Formulas in Excel contd. 
Example 1_Multistage computation of CATs result contd.  

Stage 3_Copying the formulas in row 2 to the remaining rows: 

• Select  cell L4. 

• Move the cursor over the fill handle in the bottom right corner of the 
selected cell. It will change to a black cross.  

• Hold down the left mouse button and drag the cross over the 
remaining rows in column L. The values in cells L5 to L7 are 
automatically calculated. 

• Select cell M4 and repeat the procedure described above for 
automatic calculation of the values in cells M5 to  M7. 
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Formulas in Excel contd. 
Example 2_Multistage computation of 1st Semester Exam result  

• After the students have written the 1st Semester Examination, 
and the results have been entered as shown in columns C to G. 

• You are to compute the sum of scores for the 1st Semester 
Exam, to a maximum of 70% (in column H), add the previously 
computed CATs 1 and 2 result, to a maximum of 30%  (in column 
I), and compute the final score, to a grand total of 100% (in 
column J). Again, multistage computation is required.  
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Formulas in Excel contd. 
Example 2_Multistage computation of 1st Semester Exam result contd. 
 

 

 

 
Stage 1_Computation of Total for Question 1 to 5, to a maximum of 70% (in Column H): 

• Click on cell H4. 

• Click on the Formula bar, type in = SUM(C4:G4)*70%, and click [ENTER]. This adds 
the values in cells C4 to G4, multiplies it by 70% , and displays the result in cell H4 
(i.e., to a maximum of 70%).  

• Press [ENTER] to display the result (i.e 43.225). 
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Formulas in Excel contd. 
Example 2_Multistage computation of 1st Semester Exam result contd. 
 

 

 

 
Stage 2_Computation of Final score, to a grand total of 100% (in Column J): 

• Click on cell J4. 

• Click on the Formula bar, type in = H4+I4, and click [ENTER]. This adds the values in cell 
H4 (1st Semester Exam total to a maximum of 70%) and I4 (CATs total to a maximum of 
30%), and displays the result in cell J2 (as final score to a grand total of 100%). 

• Press [ENTER] to display the result (i.e., 57.825). 
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Formulas in Excel contd. 
Example 2_Multistage computation of 1st Semester Exam result contd.  

Stage 3_Copying the formulas in row 2 to the remaining rows: 

• Select  cell H4. 

• Move the cursor over the fill handle in the bottom right corner of the 
selected cell. It will change to a black cross.  

• Hold down the left mouse button and drag the cross over the 
remaining rows in column H. The values in cells H5 to H7 are 
automatically calculated. 

• Select cell J4 and repeat the procedure described above for 
automatic calculation of the values in cells J5 to  J7. 
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Formulas in Excel contd. 
Adding Remarks using IF() Function 
• Finally, remarks are made using the IF() Function. 

• The IF() function checks for a specific condition, if the condition is met, then one action 
is taken; if the condition is not met, then a different action is taken. 

• The structure of the IF() function is:  

      = IF(condition, ”result if true”, “result if false”). 

To add Remarks using IF() Function (in column K): 
• Click on cell K4. 

• Click on the Formula bar, type in = IF(J4 <50, ”FAIL”, ”PASS”), and click [ENTER]. This assigns FAIL for 
scores less than 50, and PASS for scores of 50 and above, and displays the result in cell K4 (as Remarks). 

• Press [ENTER] to display the result (i.e., FAIL or PASS). 

• Select cell K4, move the cursor over the fill handle in the bottom right corner of the selected cell. It will 
change to a black cross.  

• Hold down the left mouse button and drag the cross over the remaining rows in column K. The Remarks  
for cells K5 to K7 are automatically inserted. 
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In the formula entered, a space  
should be inserted between: 
 J4 and < 50, 
<50, and “FAIL”, 
“FAIL”, and “PASS”  



Formulas in Excel contd. 
Example 3_Performing descriptive analysis in Excel  

Descriptive analysis (such as mean, median, mode and standard 
deviation) of quantitative data can be performed in MS Excel. 
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To compute the mean for a dataset: 

• Click in the cell immediately after the 
last entry in the dataset for the 
variable concerned (i.e., cell B106). 

• Type =AVERAGE(B2:B105) since the 
dataset under the variable age 
extends from B2 to B105), and press 
Enter. 

• The mean age (i.e., 12) is displayed in 
the selected cell. 



Formulas in Excel contd. 
Example 3_Performing descriptive analysis in Excel contd. 
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To compute the median for a dataset: 

• Click in the cell immediately after the 
cell where the last computation was 
done (i.e., cell B107). 

 

• Type =MEDIAN(B2:B105) since the 
dataset under the variable age 
extends from B2 to B105), and press 
Enter. 

 

• The median age (i.e., 12) is displayed 
in the selected cell. 



Formulas in Excel contd. 
Example 3_Performing descriptive analysis in Excel contd. 
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To compute the mode for a dataset: 

• Click in the cell immediately after the 
cell where the last computation was 
done (i.e., cell B108). 

 

• Type =MODE(B2:B105) since the 
dataset under the variable age 
extends from B2 to B105), and press 
Enter. 

 

• The modal age (i.e., 12) is displayed in 
the selected cell. 

The results show that the ages of the school pupils in the study are normally distributed 
as the mean, median and mode are equal (i.e., 12)    



Formulas in Excel contd. 
Example 3_Performing descriptive analysis in Excel contd. 
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To find the standard deviation for a 
dataset: 

• Click in the cell immediately after the 
cell where the last computation was 
done (i.e., cell B109). 

 

• Type =STDEV(B2:B105) since the 
dataset under the variable age 
extends from B2 to B105), and press 
Enter. 

 

• The standard deviation (i.e., 2.37) is 
displayed in the selected cell. 



Formulas in Excel contd. 
Deleting a Formula 
When you delete a formula, the resulting values of the formula is also deleted. It is possible 
to remove the formula only and leave the resulting value of the formula displayed in the 
cell. 

To delete formulas along with their resulting values: 

• Select the cell or range of cells that contains the formula. 

• Press [DELETE]. 

 

To delete formulas without removing their resulting values: 

• Select the cell or range of cells that contains the formula. 

• On the Home tab, find the Clipboard group and click Copy            . 

• On the Home tab, in the Clipboard group, click the arrow below Paste         ,        

      and then click Paste Values. 
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Creating Charts in Excel 

• Charts are used to display series of numeric data in a graphical format to make it 
easier to understand large quantities of data and the relationship between 
different series of data. 

To create a chart: 

• Select or enter the numeric data you want to include in the chart (together with 
the column heading) on a worksheet. 

• On the Insert tab, find the Charts group and select the preferred chart type. 

• Click a chart subtype from the drop menu that will appear. 

• The chart appears in the current window. 
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Creating Charts in Excel contd. 
Components  of a chart 

• The components of a chart include: 

1. Chart area: This is the entire chart and all its 
elements. 

2. Plot area: This is the area of the chart 
bounded by the axes. 

3. Data points: These are individual values 
plotted in a chart  represented by bars, 
columns, lines or pies. 

4. Horizontal (category) and vertical (value) 
axes along which the data is plotted in the 
chart. 

5. Legend: This identifies the patterns or colors 
that are assigned to the data series or 
categories in the chart. 

6. Axes titles: These are descriptive text for 
the axes. 

7. Data label: This provides additional 
information about a data marker that you 
can use to identify the details of a data point 
in a data series. 90 



Creating Charts in Excel contd. 

To change Chart Layout: 

• Click anywhere in the chart 

• Go to Chart Tools, and click on the Design tab. 

• In the Chart Layouts group, select the chart layout that you want to use. To 
see all available layouts , click on the drop down arrow. 
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Creating Charts in Excel contd. 

To change Chart Style: 

• Click anywhere in the chart 

• Go to the Design tab, in the Chart Styles group, click the chart style that you 
want to use. To see all predefined chart styles, click on the draw down 
arrow. 
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Creating Charts in Excel contd. 

To add Axis Title: 
• Click anywhere in the chart 

• On the Layout tab, find the Labels group, and click Axis Titles. 

• Do one or more of the following: 

     a. To add a title to a primary horizontal (category) axis, click Primary Horizontal Axis Title,  

          and then click the option that you want. 

      b. To add a title to a primary vertical (value) axis, click Primary Vertical Axis Title, and then  

           click the option that you want.  

• In the Axis Title text box that appears in the chart, type the text that you want. 

• To remove an axis title, click Axis Title, click the type of axis title to remove, and then click None. 
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Creating Charts in Excel contd. 

To add Data Labels: 
• On a chart, do one of the following: 

       a. Click on the chart area to add a data label to all data points of a data series. 

        b. Click in the data series to add a data label to all data points  of a data series. 

        c. Click on a specific data point to add a data label to a singe data point in a  data series. 

• On the Layout tab, in the Labels group, click Data Labels, and then click the display option that you want. 

• Text boxes will appear in the area of your chart based on your selection. 

• Click on the text box to modify the text. 

• To remove data labels, click Data Labels, and then click None. 

       (Depending on the chart type that you used, different data label options will be available) 
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Creating Charts in Excel contd. 

To hide or show a Legend: 
• When you create a chart, the legend appears, but you can hide the legend or change its location after 

creating the chart. 

• Click the chart in which you want to show or hide the legend. 

• On the Layout tab, in the Labels group, click Legend. 

• Do one of the following: 

       a. To hide the legend, click None. 

        b. To display a legend, click the display option that you want.. 

        c. For  additional options, click More Legend Options, and then select the display option that you want 

       (To quickly remove a legend or a legend entry from a chart, you can select it and then press DELETE) 
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Creating Charts in Excel contd. 

To remove Gridlines: 
• When you create a chart, gridlines appear, it is preferable to remove them to make your chart neat. 

• Click the chart in which you want to remove gridlines. 

• On the Layout tab, in the Axes group, click Gridlines. 

• Select Primary Horizontal Gridlines and click None. 

96 



Creating Charts in Excel contd. 

Inserting graphics in a worksheet: 
• Sometimes you may want to add graphics such as a corporate logo to a worksheet. Images such as 

ClipArt and SmartArt are available in Excel, along with a host of cut-out shapes that you can use to label 
your chart. They are all on the Insert tab,  in the Illustrations group. 

 

To insert graphics (e.g., shapes) in a chart: 
• Click the chart in which you want to insert graphics. 

• On the Insert tab, in the Illustrations group, click the graphic of choice (in this case Shapes). 

• Select the shape of your choice and drag it to the place you want it to be in the chart. 

• If you want to type some thing inside the shape, select a text box, drag it inside the shape and type what 
you want to type in it.  

      (In this case a callout shape highlighting male predominance has been inserted in the chart). 
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Creating Charts in Excel contd. 

To Move or Resize Chart: 
• You can move a chart to any location on a worksheet or to a new or existing worksheet. You can also 

change the size of the chart for a better fit. 

• To move a chart , drag it to the location that you want. 

• To resize a chart, click on one of the edges  and drag towards the center. 

 

To move chart to a New Sheet: 
• On the Design tab, in the Location group, click Move Chart. 

• Under Choose where you want the chart to be placed, click on the New sheet bubble. 

• Type a new chart name in the New sheet box, and click OK. 
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Creating  different types of Charts in Excel. 
(Column or Vertical Bar Chart) 

 
To create a Column (or Vertical Bar Chart): 

• Step1: Type in your data in a worksheet (with the columns’ headings properly 
labelled) and select/highlight the data. 

• Step 2: On the Insert tab, in Charts group, click Column, use the draw down arrow to 
select the design of choice. 
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Creating  different types of Charts in Excel contd. 
(Column or Vertical Bart Chart contd.) 

 
To create a Column (or Vertical Bar Chart) contd.: 

• Step 2 contd.: The arrangement of data is usually dictated by the design of choice. The 
types of column (vertical bar chart) are as shown below: 
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Creating  different types of Charts in Excel contd. 
(Column or Vertical Bar Chart contd.) 

 
To create a Column (or Vertical Bar Chart) contd.: 

• Step 3: To format the style, click on the Design tab in Chart Tools, and select the style of 
choice in the Chart styles group. 

 

 

 

 

 

 

 

 

 

 

 

• Step 4: Add Axis Title (as appropriate) as earlier described. 

• Step 5: Add Data Labels as earlier described. 

• Step 6: Hide, show  or reposition the Legend (as appropriate) as earlier described. 

• Step 7: Remove Gridlines (in this case horizontal gridlines) as earlier described. 
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Creating  different types of Charts in Excel contd. 
(Bar or Horizontal Bar Chart) 

 
To create a Bar (or Horizontal Bar Chart): 

• Step1: Type in your data in a worksheet (with the columns’ headings properly 
labelled) and select/highlight the data. 

• Step 2: On the Insert tab, in Charts group, click Bar, use the draw down arrow to 
select the design of choice. 
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Creating  different types of Charts in Excel contd. 
(Bar or Horizontal Bar Chart contd.) 

 
To create a Bar (or Horizontal Bar Chart) contd.: 

• Step 3: Select the style of your choice in the various styles that show in the Chart Styles 
group of Design tab, under Chart Tools that appears after clicking on the draw down 
arrow on Bar.  

 

 

 

 

 

 

 

 

 

 

 

• Step 4: Add Axis Title (as appropriate) as earlier described. 

• Step 5: Add Data Labels as earlier described. 

• Step 6: Hide, show  or reposition the Legend (as appropriate) as earlier described. 

• Step 7: Remove Gridlines (in this case vertical gridlines) as earlier described. 
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Creating  different types of Charts in Excel contd. 
(Pie Chart) 

 
To create a Pie Chart: 

• Step1: Type in your data in a worksheet (with the columns’ headings properly 
labelled) and select/highlight the data. 

• Step 2: On the Insert tab, in Charts group, click Pie, use the draw down arrow to 
select the design of choice. 
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Creating  different types of Charts in Excel contd. 
(Pie Chart contd.) 

 
To create a Pie Chart contd.: 

• Step 2 contd.: Although different designs are available, the Simple 2D Pie Chart should 
be used instead of 3D or punched out designs (unless it is absolutely necessary).  
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Creating  different types of Charts in Excel contd. 
(Pie Chart contd.) 

 
To create a Pie Chart contd.: 

• Step 3: Select the style of your choice in the various styles that show in the Chart Styles 
group of Design tab , under Chart Tools that appears after clicking on the draw down 
arrow on Pie.  
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Creating  different types of Charts in Excel contd. 
(Pie Chart contd.) 

 
To create a Pie Chart contd.: 

• Step 4: Unlike Column and Bar, in the case of Pie Chart, Axis Title is not applicable, the 
next thing to be done is to add Data Labels. 

•  In Chart Tools, click Layout tab,  find the Labels group, and click on the draw down 
arrow on Data Label, and select More Data Label Options in the pop-up menu, 
following which Format Data Labels dialog box appears. 
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Creating  different types of Charts in Excel contd. 
(Pie Chart contd.) 

 To create a Pie Chart contd.: 

• Step 4 contd.: In the Format Data Labels dialog box, do the following: 

       - In the Label Contains section of Label Options: Deselect Value that usually appears  

          by default and select percentage. You may retain or deselect Show Leader Lines as  

          applicable. 

       - In the Label Position section of Label Options: Select Outside End, and click CLOSE. 
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To change the position of the Legend, click on 
the draw down arrow on Legend in the Labels 
group and select the position of your choice. 



Creating  different types of Charts in Excel contd. 
(Line graph) 

 
To create a Line Graph: 

Line Graph is used to present time series data, such as trend of a disease or health 
condition. 

• Step 1: Type in your data in a worksheet (with the columns’ headings properly 
labelled) and select/highlight the data. The years are entered as text [i.e., type 
inverted comma (‘) before typing the year+ and not as numbers, this is to enable Excel 
treat them as categories. 

• Step 2: On the Insert tab, in Charts group, click Line, use the draw down arrow to 
select the design of choice. 
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Creating  different types of Charts in Excel contd. 
(Line graph contd.) 

 
To create a Line Graph contd.: 

• Step 3: To format the style, click on Design tab, under Chart Tools, and select the style 
of choice in the Chart styles group. 

 

 

 

 

 

 

 

 

 

 

• Step 4: Add Axis Title (as appropriate) as earlier described. 

• Step 5: Add Data Labels as earlier described. 

• Step 6: Retain or click on the Series and delete it (as appropriate). 

• Step 7: Remove Gridlines as earlier described. 
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Copying Charts to MS Word document 

To copy Charts to MS Word document or Power Point slide: 
• Click on the chart you wish to copy and select copy. 

• Create space in the MS Word document or Power Point slide you wish to  copy the Chart to. 

• Paste the chart  in the selected area. You can still format the chart in the MS Word  document or Power 
Point slide. Finally, type the Title of the Chart below it (as shown below). 
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    DATA MANIPULATION 
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Sorting data 

• The sort function sorts your data records based on the criteria that you specify. You 
can sort numbers, text or dates in either ascending (default) or descending order. 
Blank cells are always placed last in a sort. 

 To sort data in a single column: 

• Click anywhere in the column that you want to sort by. 

• On the Home tab, in the Editing group, click Sort & Filter drop down arrow and do 
one of the following: 

      - To sort in ascending or smallest to largest order, click                                         

      - To sort in descending or largest to smallest order, click 

• Your data will be sorted based on the value in the column that you initially  clicked 
on. 
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Sorting data contd. 

To sort data in a single column contd: 

• Sorting Table 1 by: 

     - class (alphabetically from A to Z) gives Table 2 

     - age (in ascending order) gives Table 3 as shown below. 
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Sorting data contd. 
• Data can also be sorted based on two or more criteria (columns). 

To sort data in multiple columns (i.e., Custom Sort): 

• Click in the data table or select the cells to be sorted. 

• On the Home tab, in the Editing group, select Sort & Filter. And choose Custom 
Sort. The Sort Window will open. 

 

 

 

 

 

 

• In the Sort by field, use the drop-down arrow to select the column that you want to 
sort by and the order (e.g., Smallest to Largest) to be used. 

• If you want to add another sort criterion, then click the Add Level button, and a 
second details row will appear in the window. Again choose the sort column and 
sort order. 

• Add more levels (or Delete Level) as required. 

• When you click the OK button at the bottom of the window, your data will be 
sorted. 115 The Sort function is also available from the Data tab 



Sorting data contd. 

To sort data in multiple columns (i.e., Custom Sort) contd.: 

• Sorting Table 1 by both class [a] and age [b]gives Table 2 as shown below. 
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Filtering data  

• The filter function lets you view just the records that you want to see. The other 
records in your data table will still be there, but hidden. 

  

To filter data: 

• On the Home tab, in the Editing group, select Sort & Filter, and select the Filter 
option. 

 

• In the first row of your data table, a drop-down arrow will appear on the right of 
each column heading. When you click on the drop-down arrow, you’ll see a list of 
all the values occurring in that column. Press [ESC] to close the filter list. 
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Filtering data contd.  

To filter data contd.: 

• If you want to view records with a particular value only, click to uncheck the Select All 
option, and then check one or more values that you want to view. Click the OK button. 

• All rows that do not contain the value(s) you checked, will be hidden from view. A 
column that has been filtered will show a funnel icon next to the drop-down arrow on 
the heading. 

 

 

 

 

 

 

•  Repeat the filtering process for as many columns as you need. You can remove a 
column filter by checking its Select All option. 

 To clear your previous filter settings, select Sort & Filter, and then Clear. 

 To turn off filtering, select Sort & Filter, and then Filter (the same option that you 
originally used to turn it on). 

118 The Sort function is also available from the Data tab 



Filtering data contd.  

To filter data contd.: 

• To view the data of only the students in Primary 2a 
(p2a), click on the data table and carry out the 
following:  

• On the Home tab, in the Editing group, select Sort & 
Filter, and select the Filter option (a drop-down arrow 
will appear on the right of each column heading). 

• Click on the drop down arrow on the right of class 
column. 

• In the dialog box that appears, deselect the Select All 
option, select p2a and click OK.  A funnel icon appears 
next to the drop-down arrow on the filtered column. 

• Only the students Primary 2a (p2a) are displayed. 
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Filtering data contd.  

To filter data contd.: 
• To view the data of a patient coming for follow up visit at the 

hospital without the hospital card but could remember the file 
number;  click on the data table and carry out the following:  

• On the Home tab, in the Editing group, select Sort & Filter, 
and select the Filter option (a drop-down arrow will appear on 
the right of each column heading). 

• Click on the drop down arrow on the right of ID number. 

• In the dialog box that appears, deselect the Select All option, 
type in the patient’s ID number (128) in the Search box that 
appears, the typed ID number will appear among the options, 
select it and click OK.  A funnel icon will appear next to the 
drop-down arrow on the filtered column. 

• Names of patients’ coming to the hospital without the hospital 
card and couldn’t remember the file number can also be used. 
If it is only one patient that bears the name in the data base, 
only the name is displayed. If there are other patients with the 
same name, all of them are displayed, you can then use other 
criteria in the data to identify the data of the patient being 
considered. 
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Simple random sample 

• A simple random sample is a subset of a statistical population in which each 
member of the subset has an equal probability of being chosen.  

• This process and technique is known as simple random sampling. 

Simple random sampling is a basic type of sampling, since it can be a 
component of other more complex  probability sampling methods. 

 

Traditional drawing (simple random sampling) methods: 
Several traditional drawing (simple random sampling) methods exist, but they 
are only feasible for smaller numbers. They include: 

  - rolling of dice 

  - shuffling of playing cards 

  - coin flipping 

  - lucky dip 

• Because of the mechanical nature of these methods, generating large 
numbers of sufficiently random numbers (important in statistics) required a 
lot of work and/or time. Random number generators are now used instead 
of the traditional drawing (simple random sampling ) methods. 
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Random numbers 

These are numbers that occur in a sequence such that two conditions 
are met. 

• The values are uniformly distributed over a defined interval or set. 

• It is impossible to predict future values based on past or present 
ones. 

 

 

Use of random number generators: 

Random number generators are used in: 

  - Statistical sampling 

  - Completely randomized design 

  - Computer simulation 

  -  Cryptography 

  -  Gambling 

  - Other areas where producing an unpredictable number is desired. 
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Random numbers are a set of digits (i.e., 0,1,2,3,4,5,6,7,8,9) arranged in 

random order. Because they are randomly ordered, no individual digit can 

be predicted from knowledge of any other digit or group of digits 

A random number generator is a  

process that produces random 

numbers. 

Any random process (e.g., flip of a 

coin or the toss of a die) can be 

used to generate random numbers.  

Statistical algorithm is used to 

produce computer generated 

random numbers 



Generating random numbers in Excel 

• Excel has two functions when it comes to generating 
random numbers, the RAND and RANDBETWEEN 
functions. 

 

RAND function 

The RAND function generates a random decimal number 
between 0 and 1. 

• Select cell A1 

• Type =RAND() and press Enter. The RAND function takes no 
argument. 
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Generating random numbers in Excel contd. 

To generate a list of random numbers 
• Generate a random number in cell A1 as earlier described 
• Select cell A1 and then move the cursor over the small square in the bottom 

right-hand corner (the fill handle).  
•  The cursor will change from a white cross       to a black cross     . 

 
 
 
 
 
 
 
 

• Hold down the left mouse button and drag it down. 
• Note that cell A1 has changed, because  random numbers change every 

time a cell is calculated. 
• If you don’t want the random numbers to change subsequently, simply copy 

and paste them as values, clicking on any of the cells will show the value in 
the cell and not the RAND function. 125 

A listing of  

random numbers 

 is called  

random number 

 table 

To remove duplicate values: 
* Click on Data tab, select  Remove duplicates 
*Select the column(s) with duplicate values in the  
   dialog box that appears and click OK 



Generating random numbers in Excel contd. 

RANDBETWEEN function 

The RANDBETWEEN function generates a random whole 
number between two boundaries. 

• Select cell A1 

• Type =RANDBETWEEN(30,60) and press Enter.  

 

 

 

• If you want to generate random decimal numbers between 

    30 and 60, modify the RAND function as =30+30*RAND()    
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You may use the fill  

handle to fill additional 

rows and columns as 

desired 



Randomization 

• Randomization is a method based on chance alone by which study 
participants are assigned to treatment groups.  

• Randomization minimizes the differences among groups by equally 
distributing people with particular characteristics among all trial 
arms. 

 

Types of randomization techniques: 

The types of randomization techniques include: 

  -  Simple randomization 

  -  Stratified randomization 

  -  Block randomization 

  - Covariate adaptive randomization 
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Randomization contd. 

Simple randomization 

• This refers to randomization based on a single 
sequence of random assignments. 

 

• This technique maintains complete randomness of the 
assignment of a subject to a particular group. 

 

• The most common and basic method of simple 
randomization is flipping a coin. For example, with two 
treatment groups (control versus treatment) the side of 
the coin (i.e., heads-control, tails-treatment) 
determines the assignment of each subject. 
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Randomization contd. 

Stratified randomization 
• This is a randomization procedure in which strata are identified and subjects 

are randomly allocated within each.  

 

• Stratification is the process of , or result of separating a sample into several 
subsamples according to specified criteria such as age groups, socio-
economic status etc. 

 

• The effect of confounding variables can be controlled by stratifying the 
analysis of result using Mantel-Haenszel Chi-square. 

 

• For example, lung cancer is known to be associated with smoking. To 
examine the possible association between urban atmospheric pollution and 
lung cancer, while controlling for smoking, the population may be divided 
into strata according to smoking status. The association between  air 
pollution and lung cancer can then be appraised separately within each 
stratum. 

• Confounding variables can also be controlled by multivariate analysis. 129 



Randomization contd. 

Block randomization 
• The block randomization method is designed to randomize subjects into 

groups that result in equal sample sizes. Blocks are small and balanced with 
predetermined group assignments which keeps the numbers of subjects in 
each group similar at all times. 

• The block size is determined by the researcher and should be a multiple of 
the number of groups (i.e., with two treatment groups, block size of either 
4, 6, or 8). 

• After block size has been determined, all possible balanced combinations of 
assignment within the block (i.e., equal number for all groups within the 
block) must be calculated. 

• Blocks are then randomly chosen to determine the patients’ assignment 
into the groups. 

• Although balance in sample size may be achieved with this method, groups 
may be generated that are rarely comparable in terms of certain covariates. 
For example one group may have more participants with chronic diseases 
(e.g., diabetes, cancer, hypertension etc) that could confound the data and 
negatively influence the results of the clinical trial.  
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To obtain a random sample of 30 from a statistical population of 
100 and randomize into two groups 

This is done in two stages 

Stage 1: Generate random numbers 
between 1 and 100 

• Select cell A1, type 
=RANDBETWEEN(1,100) and press 
Enter. 

• Click on cell A1 and then move the 
cursor over the small square in the 
bottom right-hand corner (the fill 
handle).  

•  The cursor will change from a 
white cross       to a black cross     . 

• Hold down the left mouse button 
and drag it down. 

•  Remove duplicates. 
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To obtain a random sample of 30 from a statistical population of 
100 and randomize into two groups contd. 

 

Stage 2: Randomize the random numbers generated into two groups 

• Select cell B1, type =CHOOSE(RANDBETWEEN(1,2),”GroupA”,”GroupB”) 
and press Enter. 

• Click on cell B1 and then move the cursor over the small square in the 
bottom right-hand corner (the fill handle).  

•  The cursor will change from a white cross       to a black cross     . 

• Hold down the left mouse button and drag it down. 

 

 

 

 

 

 

• Select the first 30 random numbers with their respective groups. 
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To randomize the random numbers generated into three 

groups, the formula becomes: 

=CHOOSE(RANDBETWEEN(1,3),”GroupA”,”GroupB”,

”GroupC”) 
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    C-International Research Consultancy 

                          Our Services 
                 Design or Review of Protocol / Proposal 

We provide technical support in the design of study protocol / proposal. We provide guidance on 

formulation of research topic, specific objectives, research questions, and research hypothesis. We 

provide technical support regarding choice of appropriate study design, sample size estimation and 

sampling technique; as well as choice of appropriate method and instrument of data collection, and data 

management. We also review protocol / proposal and provide guidance on how to improve the quality in 

compliance with the guidelines of the institution concerned. 

                 Development of Data Collection Instrument 

We provide technical support in the development and validation of data collection instrument. We build 

questionnaires into the Open Data Kit (ODK) software for data collection with android phones. This saves 

the cost of printing questionnaires, makes data collection easier, eliminates non-response, enables the 

researcher to monitor the research assistants recruited for data collection (particularly, when and where 

each questionnaire was administered, taking pictures of relevant locations, etc), and eliminates the 

stressful data entry stage that usually follows completion of data collection. 

       Design of Database, Data Analysis and Interpretation of Results 

We provide technical support in the design of database, data entry, data analysis and interpretation of 

results. However, collecting data with the ODK software (instead of printed questionnaires) removes the 

need for (and the cost of) designing database and data entry. 

           Design or Review of Dissertation / Thesis / Project Report 

We provide technical support in the design of dissertation / thesis / project report (in compliance with the 

guidelines of the institution concerned). We provide guidance on data presentation (including creation and 

formatting of tables and charts).  We also review dissertation / thesis / project report and provide guidance 

on how to improve the quality in compliance with the guidelines of the institution concerned 

                              Manuscript Development 

We provide technical support in the development of manuscript (for publication of 

article extracted from completed Dissertation, Thesis and Project report). 


